mirror of
https://github.com/xen-project/xen.git
synced 2026-10-28 02:01:24 +01:00
Update Python requirement to 2.6
CentOS 5, which was the reason for the 2.4 restriction, is EOL. CentOS 6 ships 2.6. Bump the version to 2.6 in README. Update configure. Signed-off-by: Wei Liu <wei.liu2@citrix.com> Acked-by: Andrew Cooper <andrew.cooper3@citrix.com>
This commit is contained in:
1 parent
919ddc3c0e
commit
72288c1566
3 files changed
+7
-7
No files matched your search
@@ -46,7 +46,7 @@ provided by your OS distributor:
|
||||
- GCC 4.8 or later
|
||||
- GNU Binutils 2.24 or later
|
||||
* Development install of zlib (e.g., zlib-dev)
|
||||
* Development install of Python 2, v2.4 or later (e.g., python-dev)
|
||||
* Development install of Python 2, v2.6 or later (e.g., python-dev)
|
||||
* Development install of curses (e.g., libncurses-dev)
|
||||
* Development install of openssl (e.g., openssl-dev)
|
||||
* Development install of x11 (e.g. xorg-x11-dev)
|
||||
@@ -177,7 +177,7 @@ Python Runtime Libraries
|
||||
|
||||
Various tools, such as pygrub, have the following runtime dependencies:
|
||||
|
||||
* Python 2, v2.4 or later.
|
||||
* Python 2, v2.6 or later.
|
||||
URL: http://www.python.org/
|
||||
Debian: python
|
||||
|
||||
|
||||
Vendored
+4
-4
@@ -7002,15 +7002,15 @@ if test x"${PYTHONPATH}" = x"no"
|
||||
then
|
||||
as_fn_error $? "Unable to find $PYTHON, please install $PYTHON" "$LINENO" 5
|
||||
fi
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for python version >= 2.3 " >&5
|
||||
$as_echo_n "checking for python version >= 2.3 ... " >&6; }
|
||||
`$PYTHON -c 'import sys; sys.exit(eval("sys.version_info < (2, 3)"))'`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for python version >= 2.6 " >&5
|
||||
$as_echo_n "checking for python version >= 2.6 ... " >&6; }
|
||||
`$PYTHON -c 'import sys; sys.exit(eval("sys.version_info < (2, 6)"))'`
|
||||
if test "$?" != "0"
|
||||
then
|
||||
python_version=`$PYTHON -V 2>&1`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
|
||||
$as_echo "no" >&6; }
|
||||
as_fn_error $? "$python_version is too old, minimum required version is 2.3" "$LINENO" 5
|
||||
as_fn_error $? "$python_version is too old, minimum required version is 2.6" "$LINENO" 5
|
||||
else
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
$as_echo "yes" >&6; }
|
||||
|
||||
+1
-1
@@ -358,7 +358,7 @@ AS_IF([echo "$PYTHON" | grep -q "^/"], [
|
||||
],[test -z "$PYTHON"], [PYTHON="python"],
|
||||
[AC_MSG_ERROR([PYTHON specified, but is not an absolute path])])
|
||||
AX_PATH_PROG_OR_FAIL([PYTHONPATH], [$PYTHON])
|
||||
AX_CHECK_PYTHON_VERSION([2], [3])
|
||||
AX_CHECK_PYTHON_VERSION([2], [6])
|
||||
|
||||
AS_IF([test "$cross_compiling" != yes], [
|
||||
AX_CHECK_PYTHON_DEVEL()
|
||||
|
||||